Installation

Spyder is relatively easy to install on Windows, Linux and macOS. Just make sure to read and follow these instructions with care.

This section explains how to install the latest stable release of Spyder. If you prefer testing the development version, please use the boostrap script instead.

If you run into problems, before posting a report, please consult our comprehensive Troubleshooting Guide and search the issue tracker for your error message and problem description, as these methods generally fix or isolate the great majority of install-related complaints. Thanks!

Installing with an alternative distribution

Caution

While we offer alternative Spyder installation options for users who desire them, we currently lack the resources to offer individual assistance for problems specific to installing via these alternative distributions. Therefore, we recommend you switch to Anaconda if you encounter installation issues you are unable to solve on your own.

Install on Windows

Spyder is also included in the WinPython scientific Python distribution, although it doesn’t include Anaconda’s convenient conda package and environment manager like Anaconda. You can use it immediately after installing, just like with Anaconda.

Install on macOS

Thanks to the MacPorts project, Spyder can be installed using its port package manager; however, the included Spyder version may be out of date or have MacPorts-specific issues outside of Spyder’s control.

There are several versions available from which you can choose.

Attention

The MacPorts version of Spyder may currently be raising ValueError: unknown locale: UTF-8, which doesn’t let it start correctly. To fix it you will have to set these environment variables in your ~/.profile (or ~/.bashrc) file manually:

export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8

Install on GNU/Linux

Please refer to the Requirements to see what other packages you might need.

Ubuntu

Using the official package manager:

sudo apt-get install spyder3

Note

The Ubuntu package could be slightly outdated. If you find that is the case, please use the Debian package mentioned below.

Debian Unstable

Using the package manager:

sudo apt-get install spyder3

Spyder’s official Debian package is available on the Debian package repository.

Other Distributions

Spyder is also available in other GNU/Linux distributions, like

Please refer to your distribution’s documentation to learn how to install Spyder.

Installing with pip (experts only)

Warning

While this installation method is a viable option for experienced users, installing Spyder (and other SciPy stack packages) with pip can lead to a number of tricky issues. While you are welcome to try this on your own, we unfortunately do not have the resources to help you if you do run into problems, except to recommend you use Anaconda instead.

Requirements

The requirements to run Spyder are:

  • Python 2.7 or >=3.3
  • PyQt5 >=5.5
  • Qtconsole >=4.2.0 – for an enhanced Python interpreter.
  • Rope >=0.9.4 and Jedi >=0.9.0 – for code completion, go-to-definition and calltips in the Editor.
  • Pyflakes – for real-time code analysis.
  • Sphinx – for the Help pane rich text mode and to get our documentation.
  • Pygments >=2.0 – for syntax highlighting and code completion in the Editor of all file types it supports.
  • Pylint – for static code analysis.
  • Pycodestyle – for style analysis.
  • Psutil – for memory/CPU usage in the status bar.
  • Nbconvert – to manipulate Jupyter notebooks on the Editor.
  • Qtawesome >=0.4.1 – for an icon theme based on FontAwesome.
  • Pickleshare – To show import completions in the Editor and Consoles.
  • PyZMQ – To run introspection services in the Editor asynchronously.
  • QtPy >=1.2.0 – To run Spyder with different Qt bindings seamlessly.
  • Chardet >=2.0.0– Character encoding auto-detection in the Editor.
  • Numpydoc Used by Jedi to get return types for functions with Numpydoc docstrings.
  • Cloudpickle Serialize variables in the IPython kernel to send them to Spyder.

Optional modules

  • Matplotlib >=1.0 – for 2D and 3D plotting in the consoles.
  • Pandas >=0.13.1 – for viewing and editing Series and DataFrames in the Variable Explorer.
  • Numpy – for viewing and editing two or three dimensional arrays in the Variable Explorer.
  • Sympy >=0.7.3 – for working with symbolic mathematics in the IPython console.
  • Scipy – for importing Matlab workspace files in the Variable Explorer.
  • Cython >=0.21 – to run Cython files or Python files that depend on Cython libraries in the IPython console.

Installation procedure

You can install Spyder with the pip package manager, which comes by default with most Python installations. Before installing Spyder itself by this method, you need to acquire the Python programming language.

Then, to install Spyder and its other dependencies, run pip install spyder. You may need to install a Qt binding (PyQt5) separately with pip if running under Python 2.

Run without installing

You can execute Spyder from source without installing it first by the following procedure:

  1. Unzip the source package available for download on the Spyder Github repository (or clone it from Github)

  2. Change current directory to the unzipped directory

  3. Install Spyder’s requirements with:

    pip install -r requirements/requirements.txt
    
  4. Run Spyder with the command:

    python bootstrap.py
    

This is especially useful for beta-testing, troubleshooting and helping develop Spyder itself.

Updating Spyder

If you installed Spyder through Anaconda (recommended), WinPython, MacPorts, or your system package manager, update using those same methods. With Anaconda, just run (in Anaconda Prompt if on Windows) conda update anaconda to update the distribution as a whole and conda update spyder to update Spyder specifically.

If you installed Spyder via the advanced/cross-platform method, pip, run pip install --upgrade spyder. This command will also update all Spyder dependencies, so we recommend you use an isolated virtualenv or venv environment to avoid any potential unintended effects on other installed packages.

Installing a development build

If you want to try the next Spyder version before it is released, you can! You may want to do this for fixing bugs in Spyder, adding new features, learning how Spyder works or just getting a taste of what the IDE can do. For more information, please see the CONTRIBUTING.md document included with the Spyder source or on Github, and for further detail consult the Spyder development wiki.

In summary:

  1. Install the Spyder requirements.

    The recommended and easiest way to do this is with conda (although experts may prefer pip). In a fresh environment (conda create -n your-name-here -c conda-forge python=3, then activate it), run the following:

    conda install -c conda-forge/label/beta spyder=4.0.0b1
    conda install -c conda-forge python-language-server
    conda remove spyder
    

    This installs all of Spyder’s dependencies into the environment along with the stable/packaged version of Spyder, and then removes Spyder itself.

    Note

    Following the separation in v3.3 of Spyder’s console code into its own package, spyder-kernels, you’ll need to have the corresponding version of it available—0.x for Spyder 3 (3.x branch), and 1.x for Spyder 4 (master branch). The above procedure will install the 0.x version; to test the master branch (Spyder 4), you’ll need to install the corresponding 1.x version of spyder-kernels. This can be done via two methods: installing the 1.x version via conda:

    conda install -c spyder-ide spyder-kernels=1.*
    

    or pip:

    pip install spyder-kernels==1.*
    

    (and using the same respective command, replacing 1 with 0, to switch back to the Spyder 3 version), or by clone-ing the spyder-kernels git repository to somewhere on your path and checking out the appropriate branch (0.x or master) corresponding to the version of Spyder (3 or 4) you would like to run, and running the commend pip install -e at the root. For any non-trivial development work, keeping two separate virtual environments (with conda-env or venv) for Spyder 3 and 4 makes this process much quicker and less tedious.

  2. Install Git, a powerful source control management tool.

  3. Clone the Spyder source code repository with the command:

    git clone https://github.com/spyder-ide/spyder.git
    
  4. Run Spyder with the bootstrap.py script from within the cloned spyder/ directory:

    python bootstrap.py
    
  5. To keep your repository up-to-date, run git pull inside the cloned directory.

Additional help

  • For a comprehensive guide to spyder troubleshooting, including installation issues, read our Troubleshooting Guide and FAQ.
  • For general information about Spyder and its ecosystem, see our main website.
  • For bug reports and feature requests, check out our Github repository.
  • For development-oriented help and information, consult our Github wiki.
  • For discussions and help requests, you can subscribe to our Google Group.
  • For quick questions and to chat with the dev team, stop by our Gitter chatroom.